Delays on incoming keyword search data - (app.engagor.com)
Incident Report for Clarabridge Engage
Postmortem

The Post Mortem written here details the root cause, impact, and corrective actions that were taken to prevent this incident from happening.

Posted Jul 29, 2019 - 16:31 CEST

Resolved
We are done processing the backlog of delayed mentions due to this incident. All data which was missed should be in your account now. New data is coming in at the expected speed. We thank you for your patience while we worked through this!
Posted Jul 24, 2019 - 17:14 CEST
Update
We are almost done with processing the backlog of mentions. Only 3% still needs to be processed. We will update this incident as soon as we are finished. Thank you!
Posted Jul 24, 2019 - 17:01 CEST
Update
We have processed about 75% of the backlog of delayed data so far. As mentioned earlier we are already caught up entirely on Twitter data, so the remaining data which is still delayed is coming from other keyword search sources (news articles, blogs, forums, etc.). We will continue to post updates on our progress here.
Posted Jul 24, 2019 - 16:40 CEST
Update
In the past hour we have been processing a big chunk of our backlog of delayed mentions already. We prioritized on Twitter data and currently all delayed Twitter data is processed. This means that we are currently tracking tweets in realtime again. We still need to work through some of the other delayed mentions via keyword searches (news articles, blogs, forums, etc.). We thank you for your patience while we continue to work on this.
Posted Jul 24, 2019 - 15:48 CEST
Monitoring
We have taken steps to address the issues which were causing the delays on incoming data. We can see that this is having a positive effect: some of the delayed mentions will start entering your accounts now, and the overall delay is decreasing. We however still need to process the backlog of data which has build since the start of this issue, which will take time, so it is expected that you will still notice delays while this is ongoing. We will continue to share updates on the progress of this. We thank you for your patience.
Posted Jul 24, 2019 - 14:16 CEST
Update
Unfortunately we are still experiencing delays on incoming mentions via keyword searches. We are still hard at work to find the cause of these delays. We will continue to update this incident as more news becomes available.
Posted Jul 24, 2019 - 12:46 CEST
Update
We are continuing to investigate this issue.
Posted Jul 24, 2019 - 08:00 CEST
Investigating
We are noticing a delay on incoming messages via keyword searches in Clarabridge Engage. We are aware of the situation and our engineering team is investigating the issue. We will provide an update soon via this incident.
Posted Jul 24, 2019 - 05:30 CEST
This incident affected: app.engagor.com (Data Sources).